visudo sudoers中提示you must hava a tty to run sudo

3年前 (2016-11-10) Jason Liu 默认 0评论 已收录 251℃
同事在用zabbix调用lvs的脚本时在zabbix WEB端提示sorry, you must have a tty to run sudo
直接用sudo -u zabbix  ipvsadm -Ln 是可以显示结果的
可能是因为zabbix是一个不能登录的用户导致的,网上搜寻方法如下:
提示sudo: sorry, you must have a tty to run sudo解决方法

方法1.注释#Defaults    requiretty

方法2.添加Defaults:user !requiretty (指定user不需要tty)
另外:在zabbix中,经常要调用自己写的脚本,需要注意的是脚本要放在一个zabbix用户能访问到的目录下,如果是多级目录,最好让每一级的目录zabbix都有x权限

相关推荐

嗨、骚年、快来消灭0回复。